Do not upgrade your unlocked iPhone to 3.1.2

Although it’s been in news the whole day, do NOT upgrade your iPhone to 3.1.2 if it’s unlocked and you want it to stay that way.

It’s clear from the warning below that the release by GeoHot called Blackra1n will only jailbreak your iPhone on OS 3.1.2.

WARNING: Even though the GeoHot jailbreak supports 3.1.2 do not update if you are on iPhone OS 3.0.1 or 3.0. You will lose your unlock. Use PwnageTool to safely update to 3.1 without performing a baseband update. If you really must have 3.1.2 then wait for the next version of PwnageTool. If you have already updated to 3.1 or 3.1.2 without using PwnageTool then you’ve lost the ability to unlock for the time being. You can now use BlackRa1n to at least regain your jailbreak :)

So hold your horses, freedom is still a release away.

[via – Gizmodo]

Liked this article? Like us on Facebook!


Comments

3 Responses to this post

  1. steve conisbee says:

    Hi, I have a 3g that has been unlocked and jailbroken. I am using it on Orange. Now that Orange are official resellers of the iPhone does anyone know if I upgrade to 3.1.2 using iTunes will it work? I appreciate that it will no longer be jailbroken but will it work?

    Any help welcome!

  2. Will Palmer says:

    Hi, i have a 2g iphone i bought ages ago. it had the 1.1.4 firmware and was unlocked and jailbroken. I currently use an 02 sim and would appreciate if anyone could tell me what will happen if i update to 3.1.2 using Itunes.

Read previous post:
Google Suggests that Obama is..

Here's another one of those weird and funny Google suggestions that appear in the Google search. It surely says that Google Suggest...

Close